dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-mathematics / 4ti2 / 4ti2-1.6.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=true
7 # The swig subdir is not used, so we can skip running autotools in it. #518000
8 AT_NO_RECURSIVE=1
9
10 inherit autotools-utils toolchain-funcs
11
12 DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
13 HOMEPAGE="http://www.4ti2.de/"
14 SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 x86 ~x86-macos"
19 IUSE="static-libs"
20
21 DEPEND="
22         sci-mathematics/glpk:0[gmp]
23         dev-libs/gmp[cxx]"
24 RDEPEND="${DEPEND}"
25
26 AUTOTOOLS_IN_SOURCE_BUILD=1
27
28 PATCHES=(
29         "${FILESDIR}"/${PN}-1.3.2-gold.patch
30         )
31
32 src_prepare() {
33         sed \
34                 -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
35                 -i m4/glpk-check.m4 || die
36         autotools-utils_src_prepare
37 }