dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / sci-libs / xylib / xylib-1.2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils
7
8 DESCRIPTION="Experimental x-y data reading library"
9 HOMEPAGE="http://www.unipress.waw.pl/fityk/xylib/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
16 IUSE="bzip2 static-libs zlib"
17
18 RDEPEND="
19         dev-libs/boost
20         bzip2? ( app-arch/bzip2 )
21         zlib? ( sys-libs/zlib )"
22 DEPEND="${RDEPEND}"
23
24 src_configure() {
25         local myeconfargs=(
26                 $(use_with bzip2 bzlib)
27                 $(use_with zlib)
28         )
29         autotools-utils_src_configure
30 }