app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / umfpack / umfpack-5.6.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils toolchain-funcs
7
8 DESCRIPTION="Unsymmetric multifrontal sparse LU factorization library"
9 HOMEPAGE="http://www.cise.ufl.edu/research/sparse/umfpack"
10 SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
15 IUSE="doc +cholmod static-libs"
16
17 RDEPEND="
18         >=sci-libs/amd-1.3
19         sci-libs/suitesparseconfig
20         virtual/blas
21         cholmod? ( >=sci-libs/cholmod-2[-minimal] )"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         doc? ( virtual/latex-base )"
25
26 src_configure() {
27         local myeconfargs=(
28                 --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
29                 $(use_with doc)
30                 $(use_with cholmod)
31         )
32         autotools-utils_src_configure
33 }