sys-apps/gawk: stable 5.0.1 for ppc, bug #725374
[gentoo.git] / sci-libs / szip / szip-2.1-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Extended-Rice lossless compression algorithm implementation"
7 HOMEPAGE="http://www.hdfgroup.org/doc_resource/SZIP/"
8 SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
9
10 LICENSE="szip"
11 SLOT="0/2"
12 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
13 IUSE="static-libs"
14
15 RDEPEND="!sci-libs/libaec[szip]"
16 DEPEND=""
17
18 DOCS=( RELEASE.txt HISTORY.txt examples/example.c )
19
20 src_configure() {
21         econf $(use_enable static-libs static)
22 }
23
24 src_install() {
25         default
26
27         if ! use static-libs; then
28                 find "${D}" -name '*.la' -delete || die
29         fi
30 }