app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / spqr / spqr-1.2.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 AUTOTOOLS_AUTORECONF=yes
6 inherit autotools-utils
7
8 MY_PN=SPQR
9 DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
10 HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
11 SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~x86"
16 IUSE="doc metis static-libs tbb"
17 RDEPEND="sci-libs/cholmod[supernodal(+)]
18         tbb? ( dev-cpp/tbb )
19         metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 DOCS=( README.txt Doc/ChangeLog )
24 PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
25
26 S="${WORKDIR}/${MY_PN}"
27
28 src_configure() {
29         myeconfargs+=(
30                 $(use_with metis)
31                 $(use_with tbb)
32         )
33         autotools-utils_src_configure
34 }
35
36 src_install() {
37         autotools-utils_src_install
38         use doc && doins Doc/*.pdf
39 }