21c6d190c228f5eb23dc07bc67317c5bc791dde2
[gentoo.git] / sci-libs / scikits / scikits-0.1-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit python-r1
9
10 DESCRIPTION="Common files for python scikits"
11 HOMEPAGE="http://projects.scipy.org/scipy/scikits"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}.example/${PN}.example-${PV}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="examples"
18
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 RDEPEND="${PYTHON_DEPS}"
22 DEPEND="${DEPEND}"
23
24 S="${WORKDIR}"
25
26 src_install() {
27         python_moduleinto scikits
28         python_foreach_impl python_domodule scikits.example*/scikits/__init__.py
29
30         if use examples; then
31                 insinto /usr/share/doc/${PF}/examples
32                 doins -r scikits.example*/*
33         fi
34 }