app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / profnet / profnet-1.0.22.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit fortran-2 toolchain-funcs
7
8 DESCRIPTION="Neural network architecture for profacc"
9 HOMEPAGE="https://rostlab.org/"
10 SRC_URI="ftp://rostlab.org/profnet/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-3"
14 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 RDEPEND="sys-libs/libunwind"
18 DEPEND="${RDEPEND}"
19
20 src_prepare() {
21         sed \
22                 -e '/$@/s:-o:$(LDFLAGS) -o:g' \
23                 -i src-phd/Makefile || die
24 }
25
26 src_compile() {
27         emake \
28                 F77=$(tc-getF77) \
29                 FFLAGS="${FFLAGS}"
30 }
31
32 src_install() {
33         emake \
34                 DESTDIR="${D}" \
35                 prefix="${EPREFIX}/usr" \
36                 install
37 }