sci-libs/armadillo: Version bump
[gentoo.git] / sci-libs / minuit / minuit-5.28.00.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit autotools eutils toolchain-funcs
7
8 MY_PN=Minuit2
9
10 DESCRIPTION="A C++ physics analysis tool for function minimization"
11 HOMEPAGE="http://seal.web.cern.ch/seal/MathLibs/Minuit2/html/index.html"
12
13 SRC_URI="http://seal.web.cern.ch/seal/MathLibs/${MY_PN}/${MY_PN}-${PV}.tar.gz
14         doc? ( http://seal.cern.ch/documents/minuit/mnusersguide.pdf
15                    http://seal.cern.ch/documents/minuit/mntutorial.pdf )"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
20 IUSE="doc openmp static-libs"
21 DEPEND="doc? ( app-doc/doxygen )"
22 RDEPEND=""
23
24 S="${WORKDIR}/${MY_PN}-${PV}"
25
26 src_prepare() {
27         epatch "${FILESDIR}"/${PN}-5.27.02-asneeded.patch
28         rm config/m4/ac_openmp.m4
29         AT_M4DIR="config/m4" eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 $(use_enable static-libs static) \
35                 $(use_enable openmp)
36 }
37
38 src_compile() {
39         emake
40         use doc && emake docs
41 }
42
43 src_test() {
44         emake check
45         cd test/MnTutorial
46         local t
47         for t in test_*; do
48                         ./${t} || die "${t} failed"
49         done
50 }
51
52 src_install() {
53         emake DESTDIR="${D}" install
54         insinto /usr/share/doc/${PF}/MnTutorial
55         doins test/MnTutorial/*.{h,cxx}
56         if use doc; then
57                 dodoc "${DISTDIR}"/mn*.pdf
58                 dohtml -r doc/html/*
59         fi
60 }