app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / libtifiles2 / libtifiles2-1.1.6-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils
7
8 DESCRIPTION="Library for TI calculator files"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
10 SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
15 IUSE="doc nls static-libs"
16
17 RDEPEND="
18         app-arch/libarchive
19         dev-libs/glib:2
20         >=sci-libs/libticables2-1.3.3
21         >=sci-libs/libticonv-1.1.3
22         nls? ( virtual/libintl )"
23
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig
26         nls? ( sys-devel/gettext )"
27
28 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
29
30 src_prepare() {
31         cd src
32         sed -i -e "s|types\*.h|$(echo types*.h)|" Makefile.in || die
33         autotools-utils_src_prepare
34 }
35
36 src_configure() {
37         local myeconfargs=(
38                 --disable-rpath
39                 $(use_enable nls)
40         )
41         autotools-utils_src_configure
42 }
43
44 src_install() {
45         autotools-utils_src_install
46         use doc && dohtml docs/html/*
47 }