kde-frameworks/oxygen-icons: amd64 stable wrt bug #675664
[gentoo.git] / sci-libs / libticables2 / libticables2-1.3.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Library to handle different link cables for TI calculators"
9 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
10 SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
15 IUSE="debug doc nls static-libs usb"
16
17 RDEPEND="
18         dev-libs/glib:2
19         usb? ( virtual/libusb:1 )
20         nls? ( virtual/libintl )"
21
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         nls? ( sys-devel/gettext )"
25
26 DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
27
28 src_prepare() {
29         default
30         eautoreconf
31 }
32
33 src_configure() {
34         # --disable-libusb $(use_enable usb libusb10) would enable virtual/libusb:1
35         econf \
36                 --disable-rpath \
37                 $(use_enable static-libs static) \
38                 $(use_enable debug logging) \
39                 $(use_enable nls) \
40                 $(use_enable usb libusb) \
41                 $(use_enable usb libusb10)
42 }
43
44 src_install() {
45         use doc && HTML_DOCS+=( docs/html/. )
46         default
47         find "${D}" -name '*.la' -delete || die
48 }
49
50 pkg_postinst() {
51         elog "Please read README in ${EROOT%/}/usr/share/doc/${PF}"
52         elog "if you encounter any problem with a link cable"
53 }