sci-libs/gdal: 2.0.1 version version bump bug #561262
[gentoo.git] / sci-libs / libspatialindex / libspatialindex-1.8.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils
8
9 MY_PN="spatialindex-src"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="General framework for developing spatial indices"
13 HOMEPAGE="https://libspatialindex.github.com/"
14 SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
15 LICENSE="MIT"
16
17 KEYWORDS="~amd64 ~x86"
18 SLOT="0/4"
19 IUSE="debug static-libs"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_prepare() {
24         epatch "${FILESDIR}"/${PN}-1.8.1-QA.patch
25         eautoreconf
26 }
27
28 src_configure() {
29         econf \
30                 $(use_enable static-libs static) \
31                 $(use_enable debug)
32 }
33
34 src_install() {
35         default
36         use static-libs || prune_libtool_files
37 }