Use https by default
[gentoo.git] / sci-libs / liborigin / liborigin-20110829.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils multilib qt4-r2
8
9 DESCRIPTION="Library for reading OriginLab OPJ project files"
10 HOMEPAGE="http://soft.proindependent.com/liborigin2/"
11 SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${PN}2-${PV}.zip"
12
13 LICENSE="GPL-3"
14 SLOT="2"
15 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
16 IUSE="doc"
17
18 RDEPEND="
19         dev-libs/boost
20         dev-qt/qtgui:4"
21 DEPEND="${RDEPEND}
22         app-arch/unzip
23         dev-cpp/tree
24         doc? ( app-doc/doxygen )"
25
26 S="${WORKDIR}"/${PN}${SLOT}
27
28 src_prepare() {
29         mv liborigin2.pro liborigin.pro || die
30         qt4-r2_src_prepare
31         cat >> liborigin.pro <<-EOF
32                 INCLUDEPATH += "${EPREFIX}/usr/include/tree"
33                 headers.files = \$\$HEADERS
34                 headers.path = "${EPREFIX}/usr/include/liborigin2"
35                 target.path = "${EPREFIX}/usr/$(get_libdir)"
36                 INSTALLS = target headers
37         EOF
38         # use system one
39         rm -f tree.hh || die
40 }
41
42 src_compile() {
43         qt4-r2_src_compile
44         if use doc; then
45                 cd doc && \
46                         doxygen Doxyfile || die "doc generation failed"
47         fi
48 }
49
50 src_install() {
51         local DOCS="readme FORMAT"
52         use doc && local HTML_DOCS=( doc/html/. )
53         qt4-r2_src_install
54 }