Use https by default
[gentoo.git] / sci-libs / libnova / libnova-0.14.0.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit eutils
7
8 DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
9 HOMEPAGE="http://libnova.sourceforge.net/"
10 SRC_URI="https://dev.gentoo.org/~bicatali/${P}.tar.gz"
11 # bad tar ball on sf, rebuild it from svn
12 #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
17 IUSE="doc examples static-libs"
18
19 DEPEND="doc? ( app-doc/doxygen )"
20 RDEPEND=""
21
22 src_configure() {
23         econf $(use_enable static-libs static)
24 }
25
26 src_compile() {
27         emake
28         use doc && emake doc
29 }
30
31 src_install() {
32         default
33         use doc && dohtml doc/html/*
34         if use examples; then
35                 make clean
36                 rm -f examples/Makefile*
37                 insinto /usr/share/doc/${PF}
38                 doins -r examples
39         fi
40 }