dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-libs / libint / libint-1.1.6.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=true
7
8 inherit autotools-utils fortran-2 toolchain-funcs versionator
9
10 MY_PV="$(replace_all_version_separators -)"
11
12 DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
13 HOMEPAGE="https://github.com/evaleev/libint"
14 SRC_URI="https://github.com/evaleev/libint/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
15
16 SLOT="1"
17 LICENSE="GPL-2"
18 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
19 IUSE="static-libs"
20
21 S="${WORKDIR}/${PN}-release-${MY_PV}"
22
23 PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
24
25 src_prepare() {
26         mv configure.{in,ac} || die
27         autotools-utils_src_prepare
28 }
29
30 src_configure() {
31         local myeconfargs=(
32                 --enable-deriv
33                 --enable-r12
34                 --with-cc=$(tc-getCC)
35                 --with-cxx=$(tc-getCXX)
36                 --with-cc-optflags="${CFLAGS}"
37                 --with-cxx-optflags="${CXXFLAGS}"
38         )
39         autotools-utils_src_configure
40 }