sci-libs/vtk: remove bogus dependency
[gentoo.git] / sci-libs / libdap / libdap-3.18.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools flag-o-matic
7
8 DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
9 HOMEPAGE="https://www.opendap.org"
10 SRC_URI="https://www.opendap.org/pub/source/${P}.tar.gz"
11
12 LICENSE="|| ( LGPL-2.1 URI )"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
15 IUSE="static-libs test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-libs/libxml2:2
20         net-misc/curl
21         sys-libs/zlib"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         sys-devel/flex
25         test? ( dev-util/cppunit )"
26
27 PATCHES=(
28         "${FILESDIR}/${PN}-3.18.1-fix-buildsystem.patch"
29         "${FILESDIR}/${PN}-3.18.1-fix-c++14.patch"
30         "${FILESDIR}/${PN}-3.18.1-disable-cache-test.patch"
31         "${FILESDIR}/${PN}-3.18.1-disable-dmr-tests.patch"
32         "${FILESDIR}/${PN}-3.18.1-disable-net-tests.patch"
33         "${FILESDIR}/${PN}-3.18.1-disable-broken-tests.patch"
34 )
35
36 src_prepare() {
37         default
38         eautoreconf
39 }
40
41 src_configure() {
42         # bug 619144
43         append-cxxflags -std=c++14
44
45         econf \
46                 --enable-shared \
47                 $(use_enable static-libs static)
48 }
49
50 src_install() {
51         default
52
53         # package provides .pc files
54         find "${D}" -name '*.la' -delete || die
55 }