app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / libctl / libctl-3.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit fortran-2 autotools-utils
7
8 DESCRIPTION="Guile-based library for scientific simulations"
9 HOMEPAGE="http://ab-initio.mit.edu/libctl/"
10 SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
15 IUSE="doc examples static-libs"
16
17 DEPEND="
18         dev-scheme/guile
19         sci-libs/nlopt"
20 RDEPEND="${DEPEND}"
21
22 src_install() {
23         autotools-utils_src_install
24         use doc && dohtml doc/*
25         if use examples; then
26                 insinto /usr/share/doc/${PF}/examples
27                 doins "${AUTOTOOLS_BUILD_DIR}"/examples/{*.c,*.h,example.scm,Makefile}
28                 doins "${S}"/examples/{README,example.c,run.ctl}
29         fi
30 }