app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / freesteam / freesteam-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils multilib scons-utils toolchain-funcs subversion
7
8 DESCRIPTION="Open source implementation of IF97 steam tables"
9 HOMEPAGE="http://freesteam.sourceforge.net/"
10 SRC_URI=""
11 ESVN_REPO_URI="https://svn.code.sf.net/p/freesteam/code/trunk"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 RDEPEND="sci-libs/gsl"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         epatch \
23                 "${FILESDIR}"/${PN}-flags.patch
24                 "${FILESDIR}"/${PN}-soname-symlinks.patch
25         epatch_user
26 }
27
28 src_configure() {
29         myesconsargs=(
30                 INSTALL_PREFIX=/usr
31                 INSTALL_LIB=/usr/$(get_libdir)
32                 INSTALL_ROOT="${D}"
33
34                 CC="$(tc-getCC)"
35                 SWIG=false
36         )
37
38         mkdir -p "${D}" || die
39 }
40
41 src_compile() {
42         escons
43 }
44
45 src_install() {
46         escons install
47 }