app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / sci-libs / freesteam / freesteam-2.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils multilib scons-utils toolchain-funcs
7
8 DESCRIPTION="Open source implementation of IF97 steam tables"
9 HOMEPAGE="http://freesteam.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/freesteam/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="sci-libs/gsl"
18 DEPEND="${RDEPEND}"
19
20 src_prepare() {
21         epatch \
22                 "${FILESDIR}"/${PN}-flags.patch
23                 "${FILESDIR}"/${PN}-soname-symlinks.patch
24         epatch_user
25 }
26
27 src_configure() {
28         myesconsargs=(
29                 INSTALL_PREFIX=/usr
30                 INSTALL_LIB=/usr/$(get_libdir)
31                 INSTALL_ROOT="${D}"
32
33                 CC="$(tc-getCC)"
34                 SWIG=false
35         )
36
37         mkdir -p "${D}" || die
38 }
39
40 src_compile() {
41         escons
42 }
43
44 src_install() {
45         escons install
46 }