sci-libs/dealii: fix QA warnings
[gentoo.git] / sci-libs / cxsparse / cxsparse-3.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib-minimal
7
8 DESCRIPTION="Extended sparse matrix package"
9 HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
10 SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
15 IUSE="static-libs"
16
17 BDEPEND="virtual/pkgconfig"
18 DEPEND=">=sci-libs/suitesparseconfig-5.4.0[${MULTILIB_USEDEP}]"
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}/${PN}-3.2.0-header.patch" )
22
23 multilib_src_configure() {
24         ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
25 }
26
27 multilib_src_install_all() {
28         einstalldocs
29
30         # package provides .pc files
31         find "${D}" -name '*.la' -delete || die
32 }