Merge media-sound/spotify: Fix homepage URL
[gentoo.git] / sci-libs / colpack / colpack-1.0.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 AUTOTOOLS_IN_SOURCE_BUILD=1
8 AUTOTOOLS_AUTORECONF=1
9
10 inherit eutils toolchain-funcs autotools-utils
11
12 MYPN=ColPack
13
14 DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
15 LICENSE="GPL-3 LGPL-3"
16 HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
17 SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
18
19 SLOT="0"
20 IUSE="openmp static-libs"
21 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
22
23 RDEPEND=""
24 DEPEND="${RDEPEND}"
25
26 S="${WORKDIR}/${MYPN}-${PV}"
27
28 PATCHES=(
29         "${FILESDIR}"/${PN}-1.0.6-flags.patch
30         "${FILESDIR}"/${PN}-1.0.8-no-bin.patch
31 )
32
33 pkg_setup() {
34         if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
35                 ewarn "You are using gcc without OpenMP"
36                 die "Need an OpenMP capable compiler"
37         fi
38 }
39
40 src_configure() {
41         local myeconfargs=(
42                 $(use_enable openmp)
43         )
44         autotools-utils_src_configure
45 }