dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-libs / coinor-flopcpp / coinor-flopcpp-1.1.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils multilib
7
8 MYPN=FlopC++
9
10 DESCRIPTION="COIN-OR algebraic modeling language for linear optimization"
11 HOMEPAGE="https://projects.coin-or.org/FlopC++/"
12 SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
13
14 LICENSE="EPL-1.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="doc examples static-libs"
18
19 RDEPEND="
20         sci-libs/coinor-cgl:=
21         sci-libs/coinor-clp:=
22         sci-libs/coinor-osi:="
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         doc? ( app-doc/doxygen[dot] )"
26
27 S="${WORKDIR}/${MYPN}-${PV}/FlopCpp"
28
29 src_prepare() {
30         # needed for the --with-coin-instdir
31         dodir /usr
32         sed -i \
33                 -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
34                 configure || die
35         autotools-utils_src_prepare
36 }
37
38 src_configure() {
39         local myeconfargs=(
40                 --enable-dependency-linking
41                 --with-coin-instdir="${ED}"/usr
42                 $(use_with doc dot)
43         )
44         autotools-utils_src_configure
45 }
46
47 src_compile() {
48         autotools-utils_src_compile
49         if use doc; then
50                 cd "${WORKDIR}/${MYPN}-${PV}/doxydoc" || die
51                 doxygen doxygen.conf || die
52         fi
53 }
54
55 src_test() {
56         autotools-utils_src_test test
57 }
58
59 src_install() {
60         use doc && HTML_DOC=("${WORKDIR}/${MYPN}-${PV}/doxydoc/html/")
61         autotools-utils_src_install
62         if use examples; then
63                 insinto /usr/share/doc/${PF}
64                 doins -r examples
65         fi
66 }