sci-libs/cblas-reference: do not remove /usr/lib, bug #596036, bug #597288
[gentoo.git] / sci-libs / coinor-dylp / coinor-dylp-1.9.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools-utils multilib
8
9 MYPN=DyLP
10
11 DESCRIPTION="COIN-OR using the dynamic simplex linear programming solver"
12 HOMEPAGE="https://projects.coin-or.org/DyLP/"
13 SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
14
15 LICENSE="EPL-1.0"
16 SLOT="0/1"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="doc examples static-libs test"
19
20 RDEPEND="sci-libs/coinor-osi:="
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         doc? ( app-doc/doxygen[dot] )
24         test? ( sci-libs/coinor-sample )"
25
26 S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
27
28 src_prepare() {
29         # needed for the --with-coin-instdir
30         dodir /usr
31         sed -i \
32                 -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
33                 configure || die
34         autotools-utils_src_prepare
35 }
36
37 src_configure() {
38         local myeconfargs=(
39                 --enable-dependency-linking
40                 --with-coin-instdir="${ED}"/usr
41                 $(use_with doc dot)
42         )
43         autotools-utils_src_configure
44 }
45
46 src_compile() {
47         autotools-utils_src_compile all $(usex doc doxydoc "")
48 }
49
50 src_test() {
51         autotools-utils_src_test test
52 }
53
54 src_install() {
55         use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
56         autotools-utils_src_install
57         # already installed
58         rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
59         if use examples; then
60                 insinto /usr/share/doc/${PF}
61                 doins -r examples
62         fi
63 }