sci-libs/coinor-sample: improve the long description in metadata.xml.
[gentoo.git] / sci-libs / brial / brial-1.2.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A C++ library for polynomials over boolean rings"
9 HOMEPAGE="https://github.com/BRiAl/BRiAl"
10 SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
11
12 # The top-level license is GPL2, but cudd/LICENSE is BSD.
13 LICENSE="BSD GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
16 IUSE="png static-libs"
17
18 BDEPEND="virtual/pkgconfig"
19 DEPEND="dev-libs/boost
20         sci-libs/m4ri[png=]"
21 RDEPEND="${DEPEND}"
22
23 pkg_setup(){
24         tc-export PKG_CONFIG
25 }
26
27 src_configure(){
28         # with-boost-libdir added to deal with some rather quirky setups
29         # see https://github.com/cschwan/sage-on-gentoo/issues/551
30         econf \
31                 --with-boost="${EPREFIX}"/usr \
32                 --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
33                 $(use_enable static-libs static)
34 }
35
36 src_install(){
37         default
38         find "${ED}" -name '*.la' -delete || die
39 }