Use https by default
[gentoo.git] / sci-libs / amd / amd-2.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools-utils fortran-2
8
9 DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
10 HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
11 SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
16 IUSE="doc fortran static-libs"
17
18 RDEPEND="sci-libs/suitesparseconfig"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig
21         doc? ( virtual/latex-base )"
22
23 src_configure() {
24         local myeconfargs=(
25                 $(use_enable fortran)
26                 $(use_with doc)
27         )
28         autotools-utils_src_configure
29 }