x11-plugins/wmpasman: x86 stable wrt bug #605862
[gentoo.git] / sci-geosciences / opencpn-plugin-watchdog / opencpn-plugin-watchdog-1.9.051.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 WX_GTK_VER="3.0"
8 MY_PN="watchdog_pi"
9 if [[ ${PV} == "9999" ]] ; then
10         EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
11         inherit git-r3 cmake-utils wxwidgets
12         KEYWORDS=""
13 else
14         SRC_URI="
15                 https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
16         "
17         inherit cmake-utils wxwidgets
18         KEYWORDS="~amd64 ~x86"
19         S="${WORKDIR}/${MY_PN}-${PV}"
20 fi
21
22 DESCRIPTION="Watchdog Plugin for OpenCPN"
23 HOMEPAGE="https://github.com/seandepagnier/watchdog_pi"
24
25 LICENSE="GPL-2+"
26 SLOT="0"
27 IUSE=""
28
29 RDEPEND="
30         x11-libs/wxGTK:${WX_GTK_VER}
31         >=sci-geosciences/opencpn-4.2.0
32         sys-devel/gettext
33 "
34 DEPEND="${RDEPEND}"
35 src_prepare() {
36         need-wxwidgets unicode
37         cmake-utils_src_prepare
38 }