www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / sci-geosciences / opencpn-plugin-objsearch / opencpn-plugin-objsearch-0.7.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 WX_GTK_VER="3.0"
7 MY_PN="objsearch_pi"
8 if [[ ${PV} == "9999" ]] ; then
9         EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
10         inherit git-r3 cmake-utils wxwidgets
11         KEYWORDS=""
12 else
13         SRC_URI="
14                 https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
15         "
16         inherit cmake-utils wxwidgets
17         KEYWORDS="~amd64 ~x86"
18         S="${WORKDIR}/${MY_PN}-${PV}"
19 fi
20
21 DESCRIPTION="Chart Object Search Plugin for OpenCPN"
22 HOMEPAGE="https://github.com/nohal/objsearch_pi"
23
24 LICENSE="GPL-2+"
25 SLOT="0"
26 IUSE=""
27
28 RDEPEND="
29         x11-libs/wxGTK:${WX_GTK_VER}
30         >=sci-geosciences/opencpn-4.2.0
31         sys-devel/gettext
32 "
33 DEPEND="${RDEPEND}"
34 src_prepare() {
35         need-wxwidgets unicode
36         cmake-utils_src_prepare
37 }