dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / sci-geosciences / opencpn-plugin-climatology / opencpn-plugin-climatology-1.0.20180316.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 WX_GTK_VER="3.0"
7 MY_PN="climatology_pi"
8 if [[ ${PV} == "9999" ]] ; then
9         EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
10         inherit git-r3 cmake-utils wxwidgets
11         KEYWORDS=""
12 else
13         SRC_URI="
14                 https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
15         "
16         inherit cmake-utils wxwidgets
17         KEYWORDS="~amd64 ~x86"
18         S="${WORKDIR}/${MY_PN}-${PV}"
19 fi
20 SRC_URI="
21         $SRC_URI
22         mirror://sourceforge/opencpnplugins/climatology_pi/CL-DATA-1.0.tar.xz -> ${PN}-1.0-CL-DATA.tar.xz
23 "
24
25 DESCRIPTION="Climatology Plugin for OpenCPN (includes CL-DATA)"
26 HOMEPAGE="https://github.com/seandepagnier/climatology_pi"
27
28 LICENSE="GPL-3+"
29 SLOT="0"
30 IUSE=""
31
32 RDEPEND="
33         x11-libs/wxGTK:${WX_GTK_VER}
34         >=sci-geosciences/opencpn-4.2.0
35         sys-devel/gettext
36 "
37 DEPEND="${RDEPEND}"
38
39 src_prepare() {
40         need-wxwidgets unicode
41         cmake-utils_src_prepare
42 }
43 src_install() {
44         cmake-utils_src_install
45         insinto "/usr/share/opencpn/plugins/${MY_PN}/data/"
46         doins "${S}"/{,../}data/*
47 }