sys-apps/coreutils: Added proper quoting of "myconf" array.
[gentoo.git] / sci-geosciences / laszip / laszip-2.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=1
7 inherit autotools-utils flag-o-matic
8
9 DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
10 HOMEPAGE="http://www.laszip.org/"
11 SRC_URI="https://github.com/LASzip/LASzip/releases/download/v${PV}/${PN}-src-${PV}.tar.gz"
12
13 SLOT="0"
14 LICENSE="LGPL-2.1+"
15 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86"
16
17 S="${WORKDIR}/${PN}-src-${PV}"
18
19 PATCHES=(
20         "${FILESDIR}"/${P}_fix-build-system.patch
21 )
22
23 src_configure() {
24         append-flags -fno-strict-aliasing
25         autotools-utils_src_configure
26 }