*/*: Replace virtual/libgudev with dev-libs/libgudev
[gentoo.git] / sci-geosciences / gtk-g-rays2 / gtk-g-rays2-2.05.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools gnome2
7
8 DESCRIPTION="GUI for accessing the Wintec WBT 201 / G-Rays 2 GPS device"
9 HOMEPAGE="http://www.daria.co.uk/gps"
10 SRC_URI="http://www.zen35309.zen.co.uk/gps/${P}.tar.xz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 RDEPEND="
18         dev-libs/glib:2
19         dev-libs/dbus-glib
20         dev-libs/libgudev
21         x11-libs/cairo
22         x11-libs/gtk+:3
23         virtual/freedesktop-icon-theme
24         net-wireless/bluez
25 "
26 DEPEND="${DEPEND}
27         virtual/pkgconfig
28         sys-devel/gettext
29 "
30
31 DOCS="README AUTHORS ChangeLog"
32
33 src_prepare() {
34         # werror is bad idea
35         sed -i -e 's:-Werror::g' configure.ac || die
36         # we run this ourselves
37         sed -i -e '/gtk-update-icon-cache/d' Makefile.am || die
38         eautoreconf
39 }
40
41 src_configure() {
42         econf \
43                 --docdir="${EPREFIX}/usr/share/doc/${PF}"
44 }