www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / sci-electronics / sigrok-cli / sigrok-cli-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit gnome2-utils python-single-r1 xdg-utils
9
10 if [[ ${PV} == "9999" ]]; then
11         EGIT_REPO_URI="git://sigrok.org/${PN}"
12         inherit git-r3 autotools
13 else
14         SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="Command-line client for the sigrok logic analyzer software"
19 HOMEPAGE="https://sigrok.org/wiki/Sigrok-cli"
20
21 LICENSE="GPL-3"
22 SLOT="0"
23 IUSE="+decode"
24 REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
25
26 RDEPEND=">=dev-libs/glib-2.32.0
27         >=sci-libs/libsigrok-0.5.0:=
28         decode? (
29                 >=sci-libs/libsigrokdecode-0.5.0:=[${PYTHON_SINGLE_USEDEP}]
30                 ${PYTHON_DEPS}
31         )"
32 DEPEND="${RDEPEND}
33         virtual/pkgconfig"
34
35 src_prepare() {
36         [[ ${PV} == "9999" ]] && eautoreconf
37         eapply_user
38 }
39
40 src_configure() {
41         econf $(use_with decode libsigrokdecode)
42 }
43
44 pkg_postinst() {
45         gnome2_icon_cache_update
46         xdg_desktop_database_update
47 }
48
49 pkg_postrm() {
50         gnome2_icon_cache_update
51         xdg_desktop_database_update
52 }