dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-electronics / petrify / petrify-4.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Synthesize Petri nets into asynchronous circuits"
7 HOMEPAGE="http://www.lsi.upc.edu/~jordicf/petrify/"
8 SRC_URI="http://www.lsi.upc.edu/~jordicf/petrify/distrib/petrify-4.2-linux.tgz"
9
10 LICENSE="Old-MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 RDEPEND="media-gfx/graphviz"
16 DEPEND=""
17
18 RESTRICT="strip"
19
20 QA_PREBUILT="/opt/petrify/petrify"
21
22 S="${WORKDIR}"/${PN}
23
24 src_install() {
25         exeinto /opt/petrify
26         doexe bin/petrify lib/petrify.lib
27         dosym petrify /opt/petrify/draw_astg
28         dosym petrify /opt/petrify/write_sg
29
30         dodoc doc/*
31         doman man/man1/*
32
33         dodir /etc/env.d
34         echo "PATH=${EPREFIX}/opt/petrify" > "${ED}"/etc/env.d/00petrify
35 }