dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / sci-electronics / iverilog / iverilog-10.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A Verilog simulation and synthesis tool"
7 SRC_URI="ftp://icarus.com/pub/eda/verilog/v${PV:0:2}/verilog-${PV}.tar.gz"
8 HOMEPAGE="http://iverilog.icarus.com/"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
13 IUSE="examples"
14
15 RDEPEND="
16         app-arch/bzip2
17         sys-libs/readline:0=
18         sys-libs/zlib:="
19 DEPEND="${RDEPEND}"
20
21 S="${WORKDIR}/${P#i}"
22
23 src_install() {
24         emake -j1 DESTDIR="${D}" install
25         einstalldocs
26         dodoc *.txt
27
28         if use examples; then
29                 dodoc -r examples
30                 docompress -x /usr/share/doc/${PF}/examples
31         fi
32 }