www-client/opera: Version 54.0.2952.41.
[gentoo.git] / sci-electronics / geda / geda-1.8.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit eutils xdg-utils flag-o-matic gnome2-utils versionator
6
7 MY_PN=${PN}-gaf
8 MY_P=${MY_PN}-${PV}
9
10 DESCRIPTION="GPL Electronic Design Automation (gEDA):gaf core package"
11 HOMEPAGE="http://wiki.geda-project.org/geda:gaf"
12 SRC_URI="http://ftp.geda-project.org/${MY_PN}/stable/v$(get_version_component_range 1-2)/${PV}/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE="debug doc examples nls stroke threads"
18
19 CDEPEND="
20         dev-libs/glib:2
21         x11-libs/gtk+:2
22         >=x11-libs/cairo-1.2.0
23         >=dev-scheme/guile-1.8[deprecated]
24         <dev-scheme/guile-2.2
25         nls? ( virtual/libintl )
26         stroke? ( >=dev-libs/libstroke-0.5.1 )"
27
28 DEPEND="${CDEPEND}
29         sys-apps/groff
30         dev-util/desktop-file-utils
31         x11-misc/shared-mime-info
32         virtual/pkgconfig
33         nls? ( >=sys-devel/gettext-0.16 )"
34
35 RDEPEND="${CDEPEND}
36         sci-electronics/electronics-menu"
37
38 S=${WORKDIR}/${MY_P}
39
40 DOCS="AUTHORS NEWS README"
41
42 src_prepare() {
43         append-libs -lgio-2.0
44         if ! use doc ; then
45                 sed -i -e '/^SUBDIRS = /s/docs//' Makefile.in || die
46         fi
47         if ! use examples ; then
48                 sed -i -e 's/\texamples$//' Makefile.in || die
49         fi
50 }
51
52 src_configure() {
53         econf \
54                 --docdir=/usr/share/doc/${PF} \
55                 $(use_enable threads threads posix) \
56                 $(use_with stroke libstroke) \
57                 $(use_enable nls) \
58                 $(use_enable debug assert) \
59                 --disable-doxygen \
60                 --disable-rpath \
61                 --disable-update-xdg-database
62 }
63
64 src_test() {
65         emake -j1 check
66 }
67
68 pkg_preinst() {
69         gnome2_icon_savelist
70 }
71
72 pkg_postinst() {
73         xdg_desktop_database_update
74         xdg_mimeinfo_database_update
75         gnome2_icon_cache_update
76 }
77
78 pkg_postrm() {
79         xdg_desktop_database_update
80         xdg_mimeinfo_database_update
81         gnome2_icon_cache_update
82 }