dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-electronics / drawtiming / drawtiming-0.7.1-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils
7
8 DESCRIPTION="Command line tool for drawing timing diagrams"
9 HOMEPAGE="http://drawtiming.sourceforge.net/index.html"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="examples"
16
17 DEPEND="media-gfx/imagemagick[cxx]"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         mv "${S}"/configure.in "${S}"/configure.ac
22         epatch "${FILESDIR}"/${P}-gcc43.patch \
23             "${FILESDIR}"/${P}-ldflags.patch
24         if has_version ">=media-gfx/imagemagick-7.0.5.7" ;then
25             epatch "${FILESDIR}"/${P}-imagemagick-7.patch
26         fi
27         eautoreconf
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install
32         dodoc AUTHORS ChangeLog README THANKS
33         if use examples; then
34                 insinto "/usr/share/doc/${PF}/examples"
35                 doins samples/*.txt
36         fi
37 }