dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-electronics / drawtiming / drawtiming-0.7.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="Command line tool for drawing timing diagrams"
9 HOMEPAGE="http://drawtiming.sourceforge.net/index.html"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="examples"
16
17 DEPEND="media-gfx/imagemagick[cxx]"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         epatch "${FILESDIR}"/${P}-gcc43.patch \
22             "${FILESDIR}"/${P}-ldflags.patch
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install
27         dodoc AUTHORS ChangeLog README THANKS
28         if use examples; then
29                 insinto "/usr/share/doc/${PF}/examples"
30                 doins samples/*.txt
31         fi
32 }