Replace all herds with appropriate projects (GLEP 67)
[gentoo.git] / sci-chemistry / wxmacmolplt / wxmacmolplt-7.5-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 WX_GTK_VER=3.0
8
9 inherit autotools eutils wxwidgets
10
11 DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
12 HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
13 SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~x86"
17 SLOT="0"
18 IUSE="flash"
19
20 RDEPEND="
21         media-libs/glew
22         media-libs/mesa
23         x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
24         flash? ( media-libs/ming )"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig"
27
28 src_prepare() {
29         need-wxwidgets unicode
30         epatch "${FILESDIR}"/${P}-glew.patch
31         sed \
32                 -e "/^dist_doc_DATA/d" \
33                 -i Makefile.am || die "Failed to disable installation of LICENSE file"
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 --with-glew \
40                 $(use_with flash ming)
41 }
42
43 src_install() {
44         default
45         doicon resources/${PN}.png
46         make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
47 }