Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / sci-chemistry / wxmacmolplt / wxmacmolplt-7.4.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 WX_GTK_VER=2.8
8
9 inherit autotools eutils wxwidgets
10
11 DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
12 HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
13 SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~x86"
17 SLOT="0"
18 IUSE="flash"
19
20 RDEPEND="
21         >=media-libs/glew-1.5.3
22         media-libs/mesa
23         x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
24         flash? ( media-libs/ming )"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-glew.patch
30         sed \
31                 -e "/^dist_doc_DATA/d" \
32                 -i Makefile.am || die "Failed to disable installation of LICENSE file"
33         eautoreconf
34 }
35
36 src_configure() {
37         econf \
38                 --with-glew \
39                 $(use_with flash ming)
40 }
41
42 src_install() {
43         default
44         doicon resources/${PN}.png
45         make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;Education"
46 }