dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / sci-chemistry / votca-xtp / votca-xtp-1.6_rc1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CMAKE_MAKEFILE_GENERATOR="ninja"
7
8 inherit bash-completion-r1 cmake-utils multilib
9
10 IUSE=""
11 if [ "${PV}" != "9999" ]; then
12         SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
14         S="${WORKDIR}/${P#votca-}"
15 else
16         inherit git-r3
17         EGIT_REPO_URI="https://github.com/${PN/-//}.git"
18         KEYWORDS=""
19 fi
20
21 DESCRIPTION="Votca excitation and charge properties module"
22 HOMEPAGE="http://www.votca.org"
23
24 LICENSE="Apache-2.0"
25 SLOT="0"
26
27 RDEPEND="
28         ~sci-libs/votca-tools-${PV}
29         >=dev-cpp/eigen-3.3
30         sci-libs/hdf5[cxx]
31         ~sci-chemistry/votca-csg-${PV}
32         sci-libs/libxc"
33
34 DEPEND="${RDEPEND}
35         virtual/pkgconfig"
36
37 DOCS=( README.md NOTICE CHANGELOG.md )
38
39 pkg_postinst() {
40         einfo
41         einfo "Please read and cite:"
42         einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
43         einfo "https://doi.org/10.1021/acs.jctc.8b00617"
44         einfo
45 }