sci-chemistry/chemical-mime-data: Drop unnecessary USE dep
[gentoo.git] / sci-chemistry / pymol-plugins-msms / pymol-plugins-msms-100415-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit eutils python-r1
10
11 DESCRIPTION="GUI for MSMS and displaying its results in PyMOL"
12 HOMEPAGE="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/msms_pymol.html"
13 SRC_URI="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/pymol_script/msms_pymol.py -> ${P}.py"
14
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 LICENSE="BSD pymol"
18 IUSE=""
19
20 RDEPEND="
21         sci-chemistry/msms-bin
22         sci-chemistry/pymol[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}"
24
25 src_unpack() {
26         mkdir "${S}" || die
27         cp "${DISTDIR}"/${A} "${S}/" || die
28 }
29
30 src_prepare() {
31         epatch "${FILESDIR}"/${PV}-msms.patch
32         sed \
33                 -e "s:GENTOOMSMS:${EPREFIX}/opt/bin/msms:g" \
34                 -e "s:GENTOOXYZRN:${EPREFIX}/usr/bin/pdb_to_xyzrn:g" \
35                 -i ${A} || die
36 }
37
38 src_install() {
39         python_moduleinto pmg_tk/startup
40         python_foreach_impl python_domodule ${P}.py
41         python_foreach_impl python_optimize
42 }