Merge remote-tracking branch 'github/pr/425'.
[gentoo.git] / sci-chemistry / pymol-plugins-emovie / pymol-plugins-emovie-1.0.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit eutils python-r1
10
11 DESCRIPTION="PyMOL plugin for convinient movie creation"
12 SRC_URI="http://www.weizmann.ac.il/ISPC/eMovie_package.zip"
13 HOMEPAGE="http://www.weizmann.ac.il/ISPC/eMovie.html"
14
15 SLOT="0"
16 LICENSE="GPL-2"
17 KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
18 IUSE=""
19
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}
23         >sci-chemistry/pymol-0.99[${PYTHON_USEDEP}]"
24 DEPEND="app-arch/unzip"
25
26 S="${WORKDIR}"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${PV}-indent.patch
30 }
31
32 src_install(){
33         python_moduleinto pmg_tk/startup
34         python_foreach_impl python_domodule eMovie.py
35         python_foreach_impl python_optimize
36 }