*/*: [QA] Remove redundant --docdir/--htmldir
[gentoo.git] / sci-chemistry / p3d / p3d-0.4.3-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 vcs-snapshot versionator
9
10 MY_P="${PN}-$(replace_version_separator 3 -)"
11 GITHUB_ID="gb8b9a75"
12
13 DESCRIPTION="Python module for structural bioinformatics"
14 HOMEPAGE="http://p3d.fufezan.net/"
15 SRC_URI="https://nodeload.github.com/fu/${PN}/tarball/${PV} -> ${P}.tar.gz"
16
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
19 LICENSE="GPL-3"
20 IUSE="examples"
21
22 src_install() {
23         distutils-r1_src_install
24
25         if use examples; then
26                 insinto /usr/share/${PN}
27                 doins -r pdbs exampleScripts
28         fi
29 }