dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / sci-chemistry / freeon / freeon-1.0.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 FORTRAN_STANDARD=90
7 PYTHON_COMPAT=( python3_6 )
8
9 inherit autotools fortran-2 python-any-r1
10
11 DESCRIPTION="An experimental suite of programs for linear scaling quantum chemistry"
12 HOMEPAGE="http://www.freeon.org"
13 SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         sci-libs/hdf5
22         virtual/blas
23         virtual/lapack"
24 DEPEND="${RDEPEND}
25         ${PYTHON_DEPS}"
26
27 PATCHES=(
28         "${FILESDIR}"/${P}-stop.patch
29 )
30
31 src_prepare() {
32         default
33         eautoreconf
34 }