Drop $Id$ per council decision in bug #611234.
[gentoo.git] / sci-chemistry / chemtool / chemtool-1.6.13.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 AUTOTOOLS_AUTORECONF=true
7
8 inherit autotools-utils eutils
9
10 DESCRIPTION="A GTK program for drawing organic molecules"
11 HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
12 SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE="emf gnome nls"
18
19 RDEPEND="
20         dev-libs/glib:2
21         media-gfx/transfig
22         x11-libs/gtk+:2
23         x11-libs/libX11
24         x11-libs/pango
25         emf? ( media-libs/libemf )"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
28
29 AUTOTOOLS_IN_SOURCE_BUILD=1
30
31 PATCHES=(
32         "${FILESDIR}"/${PV}-no-underlinking.patch
33         )
34
35 src_configure() {
36         local myeconfargs=(
37                 --without-kdedir
38                 $(use_with gnome gnomedir /usr)
39                 $(use_enable emf)
40                 --enable-undo
41                 --enable-menu
42                 )
43         autotools-utils_src_configure
44 }
45
46 src_install() {
47         autotools-utils_src_install
48
49         insinto /usr/share/${PN}/examples
50         doins "${S}"/examples/*
51         if ! use nls; then rm -rf "${ED}"/usr/share/locale || die; fi
52
53         insinto /usr/share/pixmaps
54         doins chemtool.xpm
55         make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
56 }