sci-calculators/qalculate-gtk: version bump 2.8.1
[gentoo.git] / sci-calculators / qalculate-gtk / qalculate-gtk-2.8.1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2
7
8 DESCRIPTION="Modern multi-purpose calculator"
9 HOMEPAGE="https://qalculate.github.io/"
10 SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 RDEPEND="dev-libs/glib:2
18         >=sci-libs/libqalculate-2.8.1:=
19         x11-libs/cairo
20         x11-libs/gdk-pixbuf
21         x11-libs/gtk+:3
22         x11-libs/pango"
23 DEPEND="${RDEPEND}
24         app-text/rarian
25         dev-util/intltool
26         sys-devel/gettext
27         virtual/pkgconfig"
28
29 PATCHES=(
30         "${FILESDIR}/${PN}-2.8.1-entry.patch"
31 )
32
33 src_prepare() {
34         # Required by src_test() and `make check`
35         echo data/calendarconversion.ui > po/POTFILES.skip || die
36         echo data/periodictable.ui >> po/POTFILES.skip || die
37
38         gnome2_src_prepare
39 }