sci-calculators/qalculate-gtk: version bump 2.8.1
[gentoo.git] / sci-calculators / orpie / orpie-1.5.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="A fullscreen RPN calculator for the console"
9 HOMEPAGE="http://pessimization.com/software/orpie/"
10 SRC_URI="http://pessimization.com/software/${PN}/${P}.tar.gz"
11 LICENSE="GPL-2"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc"
16
17 DEPEND="dev-ml/gsl-ocaml
18         sys-libs/ncurses:0=
19         dev-ml/camlp4"
20 RDEPEND="${DEPEND}"
21
22 PATCHES=(
23         "${FILESDIR}/${PN}-1.5.1-ocaml311.patch"
24         "${FILESDIR}/${PN}-1.5.2-nogsl.patch"
25         "${FILESDIR}/${PN}-1.5.1-orpierc.patch"
26         "${FILESDIR}/${PN}-1.5.1-tinfo.patch"
27 )
28
29 src_prepare() {
30         default
31         sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile.in || die
32         mv configure.{in,ac} || die
33         eautoreconf
34 }
35
36 src_compile() {
37         # TODO: fix missing edges in dependency graph
38         emake -j1
39 }
40
41 src_install() {
42         if use doc; then
43                 dodoc doc/manual.pdf
44                 HTML_DOCS=( doc/manual.html )
45         fi
46         default
47 }