Retirement: vapier package reassigment
[gentoo.git] / sci-calculators / hexcalc / hexcalc-1.11-r3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A simple hex calculator for X"
9 HOMEPAGE="ftp://ftp.x.org/R5contrib/"
10 SRC_URI="ftp://ftp.x.org/R5contrib/${PN}.tar.Z"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 RDEPEND="x11-libs/libXaw"
18 DEPEND="${RDEPEND}
19         x11-misc/imake
20         app-text/rman"
21
22 S=${WORKDIR}/${PN}
23
24 PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
25
26 src_compile() {
27         xmkmf || die
28         emake \
29                 CC="$(tc-getCC)" \
30                 CFLAGS="${CFLAGS}" \
31                 CCLINK="$(tc-getCC)" \
32                 LDOPTIONS="${LDFLAGS}"
33 }
34
35 src_install() {
36         dobin ${PN}
37         newman ${PN}.{man,1}
38 }