dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sci-calculators / grpn / grpn-1.4.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="A reverse polish notation (RPN) calculator based on GTK+ and libmath"
8 HOMEPAGE="http://www.getreu.net/"
9 SRC_URI="http://www.getreu.net/public/downloads/software/${PN}/${P}/${PN}_${PV}-1.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/gtk+:2
17         x11-libs/libX11"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 S="${WORKDIR}/src"
22
23 src_prepare() {
24         default
25         sed -i -e 's:= -g -O2 -I/usr/X11/include:+=:' Makefile || die
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)" DFLAGS="${LDFLAGS}"
30 }
31
32 src_install() {
33         dobin ${PN}
34         doman ${PN}.1
35
36         newicon icon.png ${PN}.png
37         make_desktop_entry ${PN} "RPN calculator"
38 }