sci-biology/ariadne: drop last-rited package
[gentoo.git] / sci-biology / sibsim4 / sibsim4-0.20.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A rewrite and improvement upon sim4, a DNA-mRNA aligner"
9 HOMEPAGE="http://sibsim4.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/SIBsim4-${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE=""
15 KEYWORDS="amd64 x86"
16
17 DEPEND=""
18 RDEPEND=""
19
20 S="${WORKDIR}/SIBsim4-${PV}"
21
22 src_prepare() {
23         sed \
24                 -e 's/CFLAGS = /CFLAGS +=/' \
25                 -e '/^CC/s:=:?=:' \
26                 -e '/^OPT/d' \
27                 -e "s:-o:${LDFLAGS} -o:g" \
28                 -i "${S}/Makefile" || die
29         tc-export CC
30 }
31
32 src_install() {
33         dobin SIBsim4
34         doman SIBsim4.1
35 }