sci-biology/recon: Version bump to 1.08
[gentoo.git] / sci-biology / recon / recon-1.06-r1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit eutils
8
9 DESCRIPTION="Automated de novo identification of repeat families from genomic sequences"
10 HOMEPAGE="http://selab.janelia.org/recon.html http://www.repeatmasker.org/RepeatModeler.html"
11 SRC_URI="http://www.repeatmasker.org/RECON${PV}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE="examples"
16 KEYWORDS="~amd64 ~x86"
17
18 S="${WORKDIR}/RECON${PV}"
19
20 src_prepare() {
21         epatch "${FILESDIR}"/${PV}-buffer-overflow.patch
22         sed -i 's|$path = "";|$path = "/usr/libexec/'${PN}'";|' scripts/recon.pl || die
23 }
24
25 src_compile() {
26         emake -C src
27 }
28
29 src_install() {
30         dobin scripts/*
31         exeinto /usr/libexec/${PN}
32         doexe src/{edgeredef,eledef,eleredef,famdef,imagespread}
33         dodoc 00README
34         insinto /usr/share/${PN}
35         use examples && doins -r Demos
36 }