media-fonts/corefonts: Remove old
[gentoo.git] / sci-biology / prints / prints-39.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 MY_PV="${PV/./_}"
6
7 DESCRIPTION="A protein motif fingerprint database"
8 HOMEPAGE="http://www.bioinf.man.ac.uk/dbbrowser/PRINTS/"
9 SRC_URI="mirror://gentoo/${P}.tar.bz2"
10
11 SLOT="0"
12 LICENSE="public-domain"
13 IUSE="emboss minimal"
14 # Minimal build keeps only the indexed files (if applicable) and the
15 # documentation. The non-indexed database is not installed.
16 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
17
18 DEPEND="emboss? ( sci-biology/emboss )"
19 RDEPEND="${DEPEND}"
20
21 src_compile() {
22         if use emboss; then
23                 mkdir PRINTS || die
24                 echo
25                 einfo "Indexing PRINTS for usage with EMBOSS."
26                 EMBOSS_DATA="." printsextract -auto -infile prints${MY_PV}.dat || die \
27                         "Indexing PRINTS failed."
28                 echo
29         fi
30 }
31
32 src_install() {
33         if ! use minimal; then
34                 insinto /usr/share/${PN}
35                 doins newpr.lis ${PN}${MY_PV}.{all.fasta,dat,kdat,lis,nam,vsn} || die \
36                         "Installing raw database failed."
37         fi
38         if use emboss; then
39                 insinto /usr/share/EMBOSS/data/PRINTS
40                 doins PRINTS/* || die "Installing EMBOSS data files failed."
41         fi
42         dodoc README || die "Documentation installation failed."
43 }